Minimum requirements for using Flow

Ensure the best possible experience of Flow by keeping your browser and OS up-to-date. Read on to see what browser and OS versions will give you the optimal results. 


We’re always looking for ways to improve our user’s experience of Flow, and part of that is a commitment to using the latest technologies and browser features as they become adopted. Because of this, very old browsers and operating system can cause problems or stop things from working entirely. To ensure that you have the best experience possible we've put together some helpful information about our supported browsers and operating systems(OS).

You can download the Flow app for your desktop from our Apps page

Desktop apps

Operating System Requirements
MacOS OS X 10.10 or above
Windows
Windows 7 or above

Mobile apps

Operating System Requirements
iOS
iOS 11.1 or above
Android Android 4.4 or above

Web apps

You can access Flow from the web anytime on your desktop at app.getflow.com. First, make sure that you're using one of our supported browsers.

Browser Requirements
Chrome Version 66 or above
Firefox Version 60 or above
Safari Version 10.1 or above
Microsoft Edge Version 41 or above
Internet Explorer Latest version only  

Unsupported browsers and OS

To ensure we’re delivering the best possible experience in Flow, we aim maintain only a short list of supported browsers and operating systems.
What does that mean? Well, when a browser or OS is supported we fix any and all annoying bugs and issues that arise. With an unsupported browser/OS, we don’t. It shouldn’t be an issue if you’re only one or two versions behind the latest version. Any older than that and you might start to notice some unexpected behaviour.  We do our best to avoid that scenario by alerting you that your browser is no longer supported so that you can update it before things get weird. 
Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.